How to install Wordpress

  • Enable GeoIP

GeoIP依赖于cURL、GMP和BCMath的PHP扩展,在WP Statistics->Optimization->Version Info中检查

cURL Version:	7.47.0
The PHP cURL Extension version you are running. cURL is required for the GeoIP code, if it is not installed GeoIP will be disabled.

Zlib gzopen():	Installed
If the gzopen() function is installed. gzopen() is required for the GeoIP database to be downloaded successfully.

GMP PHP extension:	Installed
If the GMP Math PHP extension is loaded, either GMP or BCMath is required for the GeoIP database to be read successfully.

BCMath PHP extension:	Installed
If the BCMath PHP extension is loaded, either GMP or BCMath is required for the GeoIP database to be read successfully.

如果未安装,则按下述命令安装:

$ sudo apt-get install php7.0-curl
$ sudo apt-get install php7.0-gmp
$ sudo apt-get install php7.0-bcmath
$ sudo service apache2 restart

然后配置选择允许GeoIP:WP Statistics->Settings->GeoIP settings 勾选 GeoIP collection 和 Update GeoIP Info